Tag Archives: vlan

Настраиваем trunk между коммутаторами Cisco Catalyst и 3Com

В роли Cisco будет Catalyst 4948, в роли 3Com – Switch 4210.

Просто настроить trunk было бы слишком легко, по-этому мы усложним себе задачу и сменим management vlan для 3Com. Начнем с того, что надо найти консольчик к 3Com, так как без этого ничего не получится :)

Соединяемся (19200,8,N,1,N) с 3Com и, поехали:

Read more »

VTP и MD5 Digest Mismatch

При добавлении нового коммутатора последний упрямо не хотел подсасывать VLANы с сервера. Пароли и имя домена были одинаковы. В выхлопе команды sh vtp status на коммутаторе-vtp-сервере имела место быть запись

*** MD5 digest checksum mismatch on trunk: Gi1/20 ***

ревизия базы клиента была явно меньше – 0.

Того же рода сообщения появлялись в дебаге – debug sw-vlan vtp events (не забудьте включить terminal monitor, если подключены через telnet/ssh).

Советы с форумов, сводящиеся к переводу коммутатора в режим transparent, а затем обратно в client не помогали, однако спасло добавление на vtp сервере левого vlan, подача команды no shut на нем и дальнейшее его удаление.

Cisco LACP etherchannel c несолькими виланами

После окончательного физического переноса всех серверов возникла фантазия сделать все как надо.

Первым делом было решено создать команды из сетевых интерфейсах на всех серверах и включить их в Cisco Catalyst 4948, агрегировав несколько линков в один по 802.3ad. Частный случай состоял в том, что один из серверов был гипервизором Hyper-V, а сервера, подключенные к виртуальному свичу, должны быть доступны через отдельный Vlan.

Первым делом, если еще не создан, создадим vlan:

CoreSwitchA#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
CoreSwitchA(config)#vlan 10
CoreSwitchA(config)#name Servers
CoreSwitchA(config)#exit

сконфигурируем интерфейс для управления –

CoreSwitchA(config)#int vlan 10
CoreSwitchA(config-if)#ip address 172.16.20.254 255.255.255.0
CoreSwitchA(config-if)#description to Servers VLAN
! не обязательно - адрес, чтобы форвардить запросы к DHCP серверу
CoreSwitchA(config-if)#ip helper-address 192.168.0.1
CoreSwitchA(config-if)#no shut
CoreSwitchA(config-if)#exit

создадим port-channel интерфейс, заставим его работать в транке и разрешим ему соответствующие виланы –

CoreSwitchA(config)#int port-channel 1
CoreSwitchA(config-if)#switchport 
CoreSwitchA(config-if)#switchport trunk encapsulation dot1q  
CoreSwitchA(config-if)#switchport mode trunk
CoreSwitchA(config-if)#switchport trunk allowed vlan 1,10
CoreSwitchA(config-if)#exit

осталось зайти на интерфейсы, включить dot1q энкапсуляцию, включить протокол LACP и добавить их в etherchannel port-channel 1 –

CoreSwitchA(config)#int gi1/3
CoreSwitchA(config-if)#switchport 
CoreSwitchA(config-if)#switchport trunk encapsulation dot1q
CoreSwitchA(config-if)#channel-protocol lacp
CoreSwitchA(config-if)#channel-group 1 mode active 

в случае успеха лицезреем следующее сообщение и проделываем тоже с другим портом(ами) –

*Mar 23 03:35:58.971: %EC-5-BUNDLE: Interface Gi1/3 joined port-channel Po1
CoreSwitchA(config-if)#int gi1/4
CoreSwitchA(config-if)#switchport 
CoreSwitchA(config-if)#switchport trunk encapsulation dot1q
CoreSwitchA(config-if)#channel-protocol lacp
CoreSwitchA(config-if)#channel-group 1 mode active 

that’s all, folks!

CoreSwitchA#sh etherchannel 1 summary | b Num
Number of channel-groups in use: 1
Number of aggregators:           1

Group  Port-channel  Protocol    Ports
------+-------------+-----------+-----------------------------------------------
1      Po1(SU)         LACP      Gi1/3(P)    Gi1/4(P)